Система оптического распознавания текста ABBYY® FineReader Версия 8.0

Руководство пользователя
Источник:http://www.abbyy.ru
Twitter Facebook Vkontakte

Информация, содержащаяся в этом документе, может быть изменена без предварительного уведом­ления, и компания ABBYY не берет на себя на этот счет никаких обязательств.

Глава 1. Работа с программой ABBYY FineReader 8.0


Проверка и редактирование текста

После завершения распознавания результат появляется в окне Текст. Окно Текст – это встроенный редактор программы ABBYY FineReader; в нем вы можете проверить результаты распознавания и отредактировать распознанный текст.

Одна из возможностей текстового редактора ABBYY FineReader – это встроенная проверка орфографии (список языков, для которых поддерживается проверка орфографии, приведен в разделе "Поддерживаемые языки распознавания").

Система встроенной проверки орфографии позволяет:

  • 1. Находить неуверенно распознанные слова (слова, в которых есть неуверенно распознанные символы).
  • 2. Находить орфографические ошибки (неправильно написанные слова).
  • 3. Добавлять неизвестные системе ABBYY FineReader слова в словарь для того, чтобы они распознавались уверенно.
Проверка распознанного текста

Неуверенно распознанные символы и слова, которых нет в словаре, выделяются различными цветами. По умолчанию для выделения неуверенно распознанных символов используется голубой, для несловарных слов – розовый. Чтобы изменить цвета: На закладке Вид диалога Опции (меню Сервис >Опции) в поле Объект выберите пункт Неуверенно распознанный символ (Несловарное слово) и в поле Цвет – цвет подсветки.

Чтобы проверить результаты распознавания:

  • 1. Нажмите кнопку 3–Проверить на панели Scan&Read (или выберите пункт Проверка в меню Сервис).
  • 2. Откроется диалог Проверка.
  • 3. В диалоге Проверка три окна. Верхнее окно – аналог окна Крупный план программы ABBYY FineReader, в нем показано изображение слова с возможной ошибкой. Среднее окно показывает само слово с возможной ошибкой, в строке над этим окном выводится название типа ошибки. В нижнем окне, Варианты, предлагаются варианты замены данного слова (если таковые имеются). Для вариантов используется словарь, указанный в поле Язык словаря. Вы можете использовать любой словарь из предложенного списка.
    Замечание. Для удобства проверки и редактирования текста диалог Проверка может быть увеличен. Для этого достаточно поместить указатель мыши на границу диалога (указатель превратится в двустороннюю стрелку). Перетаскивая границу, увеличьте или уменьшите размеры диалога.
  • 4. У вас есть следующие возможности:
    • Нажмите кнопку Пропустить, чтобы оставить слово, как есть.
    • Нажмите кнопку Пропустить все, чтобы оставить все такие слова в распознанном тексте, как есть.
      Замечание. При нажатии на кнопки Пропустить или Пропустить все со слова снимается "признак неуверенности" – считается, что слово не содержит нераспознанных или неуверенно распознанных символов; снимается также и визуальная подсветка таких символов в тексте. При экспорте в PDF в режиме Заменять неуверенно распознанные слова их изображениями слова, с которых при проверки был снят "признак неуверенности" (при нажатии кнопок Пропустить и Пропустить все), не будут заменены на свои изображения.
    • Выберите вариант для замены и нажмите кнопку Заменить или Заменить все, чтобы заменить текущее слово или все такие слова в тексте. Если в окне Варианты нет правильного варианта для замены слова, отредактируйте слово или несколько соседних слов в среднем окне (обратите внимание, что при переходе в режим редактирования меняется назначение некоторых кнопок диалога и соответственно – надписи на них) и нажмите кнопку Подтвердить, чтобы зафиксировать сделанные изменения и перейти к следующему фрагменту текста.
    • Нажмите Добавить..., чтобы добавить слово в словарь. В этом случае при дальнейшей проверке орфографии, если это слово (или одна из его форм) встретится в тексте, оно не будет считаться ошибочным.
    • Нажмите Опции..., чтобы установить опции проверки распознанного текста.
    • Нажмите Закрыть, чтобы закрыть диалоговое окно.
Перемещение по неуверенно распознанным словам

Для более быстрой проверки результатов распознавания вы можете воспользоваться кнопками или для перемещения к следующему или, соответственно, предыдущему неуверенно распознанному слову.

Также для перемещения по неуверенно распознанным словам можно использовать горячие клавиши: F4 (SHIFT F4).

Опции проверки и редактирования текста

Устанавливаются на закладке Проверить диалога Опции (меню Сервис >Опции) и в диалоге Дополнительные опции в группе Проверить.

Уровень выделения ошибок

В списке Уровень выделения ошибок можно выбрать следующие значения:

  • Нет – ошибки распознавания не выделяются.
  • Стандартный – цветом выделяются нераспознанные и неуверенно распознанные символы.
  • Максимальный – помимо нераспознанных и неуверенно распознанных символов, цветом выделяются слова, которых нет в словаре языка распознавания.
  • >

Замечание. Количество показываемых в окне Текст ошибок будет изменено после повторного распознавания документа.

Останавливаться на неуверенно распознанных словах

Система при проверке орфографии останавливается на словах, в которых были неуверенно распознаны какие–либо буквы.

Останавливаться на несловарных словах

Эта опция позволит вам проверить слова, которых нет в словаре, и которые могли быть распознаны программой неверно.

Останавливаться на сложных словах

При проверке орфографии система останавливается на словах, которых нет в словаре, но которые могут быть построены по имеющимся морфологическим моделям или которые могут быть составлены из имеющихся в словаре слов.

Замечание. Данная опция находится в диалоге Дополнительные опции. Для того чтобы открыть этот диалог, щелкните по кнопке Дополнительные опции на закладке Общие диалога Опции (меню Сервис >Опции).

Игнорировать слова с цифрами и другими неалфавитными символами

При проверке орфографии слова, внутри которых встречаются цифры или какие–либо другие символы, не входящие в алфавит языка распознавания, не считаются ошибочными, если эти слова не содержат неуверенно распознанные символы.

Корректировать пробелы до и после знаков препинания

Если этот пункт отмечен, то система не будет останавливаться на тех фрагментах, где неверно расставлены пробелы до и после знаков препинания, а исправит их автоматически.

Замечание. Данная опция находится в диалоге Дополнительные опции. Для того чтобы открыть этот диалог, щелкните по кнопке Дополнительные опции на закладке Общие диалога Опции (меню Сервис >Опции).

Пополнение и удаление слов из пользовательского словаря

Добавление слова в пользовательский словарь

Добавление слов в словарь – один из способов повышения качества распознавания, т.к. при распознавании система проверяет слова по словарю. В словарь имеет смысл добавлять часто встречающиеся слова (например, термины, сокращения, названия и т.д.). При добавлении слова система строит его парадигму (совокупность всех форм данного слова). Благодаря этому система может уверенно распознавать не только ту форму, которая уже однажды встретилась в тексте и была добавлена в словарь, но и все формы добавленного слова.

Чтобы добавить слово в словарь во время проверки орфографии: Нажмите кнопку Добавить в диалоге Проверка.

В диалоге Начальная форма в ы должны установить следующие параметры:

1. Часть речи (Существительное, Прилагательное, Глагол, Неизменяемое слово).

2. Если слово всегда пишется с большой буквы, отметьте пункт Имя собственное. Если в ы добавляете слово, являющееся сокращением, отметьте пункт Аббревиатура.

3. Начальная форма слова.

Нажмите ОК. Откроется диалог Построение парадигмы, в котором пользователю предлагаются вопросы, по ответам на которые строится парадигма слова. Для ответов на вопросы нажимайте кнопки Да или Нет. Если вы ошиблись при ответе на вопрос, нажмите кнопку Сначала, чтобы иметь возможность ответить на этот вопрос по–другому. Система покажет построенную парадигму в диалоге Парадигма.

Замечания.

1. Если вы хотите, чтобы при добавлении слова в английский словарь парадигма не строилась (слово добавлялось бы как неизменяемое), то на закладке Проверить диалога Опции (меню Сервис >Опции) отметьте опцию Добавлять слово как неизменяемое.

2. Вы можете добавлять слова во время просмотра списка добавленных слов. Для этого в меню Сервис выберите пункт Просмотр словарей. В открывшемся диалоге Выбор словаря выберите язык и нажмите кнопку Просмотр. Откроется словарь со списком добавленных слов. Вы можете, нажав на кнопку Добавить, добавить набранное слово.

3. Построение парадигмы при добавлении слова в словарь возможно для английского, испанского, итальянского, немецкого (новая и старая орфография), русского, украинского и французского языков.

Если добавляемое слово уже есть в словаре, система предупредит вас об этом. В этом случае вы можете посмотреть его парадигму. Если существующая парадигма вас не устраивает, можете создать другую (кнопка Добавить в диалоге Добавить слово).

Совет: Вы можете импортировать пользовательские словари, созданные в предыдущих версиях ABBYY FineReader (5.0, 6.0 и 7.0).

Чтобы импортировать словарь:

1. В меню Сервис выберите пункт Просмотр словарей. Далее выберите язык словаря и нажмите кнопку Просмотр.

2. В открывшемся диалоге Словарь нажмите кнопку Импорт и выберите файлы с расширениями (*.pmd, *.txt или *.dic).

Чтобы удалить слово из словаря:

1. В меню Сервис выберите пункт Просмотр словарей. Выберите язык словаря и нажмите кнопку Просмотр.

2. В открывшемся диалоге выделите слово и нажмите кнопку Удалить.

Редактирование текста в редакторе ABBYY FineReader

Совет: Если символы в текстовом окне ABBYY FineReader отображаются некорректно (в словах на месте некоторых букв стоят значки "?" или "?"), это означает, что шрифты, выбранные на закладке Сохранить, не содержат всех символов, входящих в распознаваемый язык. Установите шрифт (группа Шрифты, меню Сервис >Опции, закладка Сохранить), поддерживающий все символы языка документа (например, Arial Unicode MS или Bitstream Cyberbit), и перераспознайте документ. Более подробно о шрифтах для поддерживаемых языков см. раздел "Шрифты, необходимые для корректного отображения символов поддерживаемых языков в редакторе ABBYY FineReader".

Распознанный текст выводится в окно Текст. При сохранении текста в приложение оформление документа сохраняется в соответствии с опциями форматирования, устанавливаемыми на закладке Сохранить и в диалоге Форматы.

Неуверенно распознанные символы выделяются цветом. Вы можете отменить выделение слов с неуверенно распознанными символами: на закладке .Вид (меню Сервис >Опции) снимите отметку с пункта Выделять неуверенно распознанные символы.

Редактор ABBYY FineReader поддерживает два режима просмотра документа: режим с полным сохранением исходного оформления документа и черновой режим просмотра.

В режиме с полным сохранением исходного оформления документа блоки с распознанным текстом, таблицами и картинками отображаются именно там, где они были в исходном изображении. Таким образом, в этом режиме сохраняется исходный вид изображения: колонки, таблицы, картинки и буквицы (большие буквы на несколько строк в абзаце). Блок, в котором находится курсор, является активным. При перемещении курсора с помощью клавиатуры последовательность обхода блоков определяется их порядковыми номерами. Если текст блока не умещается внутри его границ (например, в результате редактирования распознанного текста), то часть текста неактивного блока может быть не видна на экране. Признаком этого являются специальные красные маркеры на границах блока. Когда блок становится активным, его границы расширяются таким образом, чтобы весь его текст был виден на экране целиком.

В черновом режиме редактора не отображаются: левый отступ; выравнивание абзаца (все абзацы прижаты к левому краю); цвет и фон символов. Для показа текста используется шрифт одного размера (по умолчанию 12 пт.). При этом сохраняется шрифт и форматирование текста: полужирный, курсив, подчеркнутый, верхние и нижние индексы.

Переход из одного режима в другой осуществляется нажатием кнопок (режим отображения исходного оформления документа) и (черновой режим редактора) в окне Текст.

Вы можете поменять установленный по умолчанию размер шрифта для показа в черновом режиме. Для этого:

1. В меню Сервис выберите пункт Опции.

2. На закладке Вид укажите нужный размер шрифта в пункте Размер шрифта в черновом режиме.

Редактор системы ABBYY FineReader предоставляет следующие возможности по редактированию текста: Копирование, вырезание, вставка выделенных фрагментов текста

1. Перед применением команд копирования, вырезания или вставки выделите нужный фрагмент текста.

2. Проделайте одно из действий:

Чтобы скопировать выделенный текст:

  • Кнопка Копировать - Нажмите кнопку Копировать на инструментальной панели Стандартная.
  • В меню Правка или в локальном меню выберите команду Копировать.
  • Нажмите клавиши ALT+C.

Чтобы вырезать фрагмент текста:

  • Кнопка Вырезать - Нажмите кнопку Вырезать на инструментальной панели Стандартная.
  • В меню Правка или в локальном меню выберите команду Вырезать.
  • Нажмите клавиши ALT+X.

Чтобы вставить скопированный (вырезанный) текст:

  • Кнопка Вставить - Нажмите кнопку Вставить на инструментальной панели Стандартная.
  • В меню Правка или в локальном меню выберите команду Вставить.
  • Нажмите клавиши ALT+V.
Поиск и замена указанного фрагмента текста

Чтобы найти определенный фрагмент в редактируемом тексте:

1. Выполните одну из следующих операций:

  • В меню Правка выберите пункт Найти.
  • Нажмите клавиши ALT+F.

2. В открывшемся диалоге Поиск в строке Найти введите слово или фрагмент текста, который вы хотите найти, и установите параметры поиска.

Замечание. Чтобы повторить поиск того же слова с теми же параметрами, нажмите клавишу F3.

Чтобы найти и заменить определенный фрагмент в редактируемом тексте:

1. Выполните одну из следующих операций:

  • В меню Правка выберите пункт Заменить.
  • Нажмите клавиши ALT+H.

2. В открывшемся диалоге Заменить в строке Найти введите слово или фрагмент текста, который вы хотите найти, в строке Заменить на укажите текст замены, и установите параметры поиска.

Изменение начертания шрифта

1. Установите курсор на слово, которое вы хотите изменить, или выделите участок текста, для которого вы хотите изменить шрифт.

2. Выполните одну из следующих операций:

  • Нажмите на одну из кнопок , , на панели Форматирование.
  • Щелкните правой кнопкой мыши в окне Текст и в локальном меню выберите пункт Шрифт.
    В открывшемся диалоге Шрифт выберите название шрифта и установите нужные вам параметры шрифта.
  • Нажмите клавиши ALT+B – полужирный, ALT+I – курсив, ALT+U – подчеркивание.

Замечание. Устанавливаемые в диалоге Шрифты цвет фона блока и форматирование текста малыми прописными (отображение всех строчных букв в выделенном тексте как прописных букв уменьшенного размера) не отображаются в окне Текст. Вы увидите эти изменения при сохранении документа в формате приложений, поддерживающих указанные типы форматирования текста.

Изменение выравнивания текста

1. Выделите текст, который необходимо выровнять.

2. Выполните одну из следующих операций:

  • Нажмите на одну из кнопок , , , на панели Форматирование.
  • Щелкните правой кнопкой мыши в окне Текст и в локальном меню выберите пункт Шрифт. В открывшемся диалоге Шрифт в поле Выравнивание выберите нужный пункт.
Отмена и восстановление действий

Выполните одну из следующих операций:

  Чтобы отменить совершенное действие:

  • Кнопка Отменить - Нажмите кнопку Отменить на инструментальной панели Стандартная.
  • В меню Правка выберите пункт Отменить.
  • Нажмите клавиши ALT+Z.

Чтобы восстановить отмененное действие:

  • Кнопка Восстановить - Нажмите кнопку Восстановить на инструментальной панели Стандартная.
  • В меню Правка выберите пункт Восстановить.
  • Нажмите клавиши ALT+Y.
Редактирование таблиц

При редактировании таблицы вы можете:

  • 1. Объединить содержимое ячеек или строк,
  • 2. Разбить содержимое ячеек,
  • 3. Разбить содержимое строки (столбца),
  • 4. Удалить содержимое ячейки.

Чтобы объединить содержимое ячеек или строк: Удерживая клавишу CTRL, выделите на изображении ячейки или строки, которые вы хотите объединить. В меню Изображение>Ячейки таблицы выберите пункт Объединить ячейки или Объединить строки.

Чтобы разбить содержимое ячеек: В меню Изображение>Ячейки таблицы выберите пункт Разбить ячейки.

Внимание! Команда применяется только к ранее объединенным ячейкам таблицы.

Чтобы разбить содержимое строки или столбца:

1. На панели Изображение выберите инструмент или .

2. Вставьте горизонтальную/вертикальную линию в строку/столбец таблицы, содержимое которых вы хотите разделить.

Замечание. Воспользовавшись инструментом или командой меню Объединить строки (меню Изображение>Ячейки таблицы), вы можете объединить содержимое строк (столбцов).

Чтобы удалить содержимое ячейки: В окне Текст выделите ячейку (или несколько ячеек), содержимое которой Вы хотите удалить, и нажмите клавишу DEL.

Редактирование и создание гиперссылок

Гиперссылка — это связь между веб–страницами или файлами. Гиперссылка состоит из текста, отображаемого в документе, и адреса. Объект, указанный в адресе гиперссылки, отображается в веб–обозревателе, открывается или запускается в зависимости от типа этого объекта. Часто гиперссылка указывает на веб–страницу, но может также указывать на рисунок, мультимедийный файл, документ, адрес электронной почты или программу.

При распознавании документа ABBYY FineReader 8.0 находит ссылки на:

  • файлы, например, file://D:\MyDocuments\ABBYY FineReaderGuide.pdf;
  • протокол передачи файлов (FTP), например, ftp://;
  • сайты, например, http://www.abbyy.com;
  • адреса электронной почты, например, mailto:office@abbyy.com.

Программа распознает текст и восстановит адрес гиперссылки в выходном документе. Все найденные гиперссылки выделяются синим цветом и подчеркиванием.

Замечание. Цвет выделения гиперссылок можно изменить в диалоге Опции на закладке Распознать.

При просмотре распознанного документа в окне Текст при наведении курсора на гиперссылку возникает всплывающая подсказка с адресом гиперссылки. Для перехода по ссылке нажмите клавишу CTRL и щелкните по ссылке левой кнопкой мыши.

Редактор системы ABBYY FineReader позволяет:

  • Изменить текст и адрес найденной гиперссылки,
  • Вставить гиперссылку в документ,
  • Удалить гиперссылку из документа.

Изменение текста и адреса гиперссылки

1. Выделите текст гиперссылки.

Если текст не был выделен, в качестве текста гиперссылки используется адрес гиперссылки;

2. Нажмите кнопку , расположенную на панели инструментов окна Текст;

3. В открывшемся диалоге Гиперссылка в поле Текст гиперссылки укажите новый текст;

4. В этом же диалоге в группе Связать с укажите новый тип адреса гиперссылки:

  • опция Веб–страница позволяет создать гиперссылку, указывающую на веб–страницу. Затем в поле Адрес укажите протокол и имя веб–страницы (например, http://www.abbyy.com);
  • опция Файл позволяет создать гиперссылку, указывающую на файл. При выборе данной опции открывается диалог Открыть, в котором необходимо выбрать имя файла, на который будет указывать ссылка;
  • опция Электронная почта создает гиперссылку, позволяющую пользователю отправить письмо по заданному адресу. Затем в поле Адрес укажите адрес электронной почты (например, mailto:office@abbyy.com).

Вставка гиперссылки в документ

1. Выделите текстовый фрагмент.

Если текст не был выделен, в качестве текста гиперссылки используется адрес гиперссылки;

2. Нажмите кнопку , расположенную на панели инструментов окна Текст;

3. В открывшемся диалоге Гиперссылка в поле Текст гиперссылки укажите текст гиперссылки;

4. В этом же диалоге в группе Связать с укажите тип адреса гиперссылки:

  • опция Веб–страница позволяет создать гиперссылку, указывающую на веб–страницу. Затем в поле Адрес укажите протокол и имя веб–страницы (например, http://www.abbyy.com);
  • опция Файл позволяет создать гиперссылку, указывающую на файл. При выборе данной опции открывается диалог Открыть, в котором необходимо выбрать имя файла, на который будет указывать ссылка;
  • опция Электронная почта создает гиперссылку, позволяющую пользователю отправить письмо по заданному адресу. Затем в поле Адрес укажите адрес электронной почты (например, mailto:office@abbyy.com).

  • опция Веб–страница позволяет создать гиперссылку, указывающую на веб–страницу. Затем в поле Адрес укажите протокол и имя веб–страницы (например, http://www.abbyy.com);
  • опция Файл позволяет создать гиперссылку, указывающую на файл. При выборе данной опции открывается диалог Открыть, в котором необходимо выбрать имя файла, на который будет указывать ссылка;
  • опция Электронная почта создает гиперссылку, позволяющую пользователю отправить письмо по заданному адресу. Затем в поле Адрес укажите адрес электронной почты (например, mailto:office@abbyy.com).

Удаление гиперссылки из документа

Щелкните по ссылке в окне Текст правой кнопкой мыши. В открывшемся контекстном меню выберите команду Удалить гиперссылку.


Предыдущая |  Следующая |  Содержание



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2019